帮助中心
Help Center articles
当您在 EA Studio 中打开收藏集页面时,它会显示表现最佳的策略。
如果您使用生成器 (Generator)创建策略,或者直接在编辑器 (Editor) 中编辑策略,应用程序会对该策略进行回测。之后,它会向您展示各种统计数据和图表。
该策略会被加入收藏集,收藏集中的策略数量最多可达 300 个。您可以通过“工具 (Tools)”来更改此数量。

应用程序默认按净余额对它们进行排序。
每当您想要添加新策略时,EA Studio 首先会将该策略的净余额与现有策略的余额进行比较。
只有当新策略的余额更高时,EA Studio 才会添加该新策略,并移除余额最低的策略。这就是应用程序如何将策略数量维持在 300 个以内的机制。

当您在收藏集中选择一个策略时,应用程序会立即将其发送到编辑器 (Editor),您可以在那里对其进行更改。
工具栏

刷新 (Refresh)– 该按钮用于刷新策略列表。如果您进入收藏集,您可能会注意到它始终向您显示表现最好的十个策略。
它根据您设置的标准对它们进行排序。假设您正在使用生成器创建策略,在这种情况下,其中一些策略可能会被移动到收藏集中。
相应地,收藏集链接(在主菜单栏中)旁边的数字将会增加。然后,刷新按钮会变为绿色,以此通知您收藏集中已添加新策略。

只要您点击该按钮,它们就会出现。为了方便起见,策略列表不会自动更新。这样,您可以浏览它们而不会因为它们的位置不断变化而感到困扰。
重新计算 (Recalculate)– 在这里您可以重新计算收藏集中的所有策略。应用程序会加载每个策略对应的市场并执行新的回测。
如果您想针对不同的经纪商数据重新计算收藏集,或者在一段时间后重新计算策略以查看其表现,此选项将非常有用。
之后,只有盈利的策略会被保留下来。
投资组合 (Portfolio)– 此选项将所有策略添加到单个投资组合 (Portfolio)中。当您点击此按钮时,EA Studio 会让您选择添加一定数量的顶级策略(从 5 到 20 个)或添加全部策略。
下载 (Download)– 您可以使用此按钮将整个策略收藏集保存到您的计算机上。文件的扩展名为“json”。这样您就可以随时轻松地查看和使用它们。
上传 (Upload)– 这是 EA Studio 的另一个有用功能。它允许您上传以前拥有的收藏集文件。因此,您可以使用一些旧的成功策略,对其进行更新并进一步优化。
全部移除 (Remove all)– 该选项会删除您在收藏集页面中的所有策略。当您决定使用新的货币对或周期来测试策略时,这会非常有用。
排序记录 (Sort records)

此参数用于对收藏集中的策略进行排序,并移除无用的策略。一旦您应用更改,策略会立即重新加载。
您可以根据回报率/回撤、胜率/损率、利润因子、净余额和其他参数对策略进行排序。
过滤记录 (Filter records)

您收集的所有策略都会出现在收藏集中。您可以根据自己的喜好对它们进行过滤。
每当您添加或移除过滤器时,EA Studio 都会自动更新,仅显示通过过滤器的策略。
使用性能过滤器 (Use performance filters)– 您可以启用或禁用这些过滤器。如果您启用了过滤器,则可以下载收藏集中的策略。请注意,应用程序仅导出可见的策略。
已通过策略 (Passed Strategies)– 这里有两个数字向您展示特定信息。
第一个数字显示当前收藏集中有多少个可见策略。
第二个数字表示收藏集中的策略总数。
移除所有隐藏策略 (Remove all hidden strategies)– 通过此按钮,您可以移除收藏集中的隐藏策略。
添加验证标准 (Add validation criteria)– 您可以在这里选择许多选项。例如:最小利润因子、最大停滞天数、最大净值回撤 % 等。
相关性分析 (Correlation Analysis)
相关性分析有两种模式可以使用:自动和手动。

生成器可能会创建与您在收藏集中已有的策略类似的策略。确保您没有此类策略是非常重要的。
如您所知,拥有不同的策略是一种良好的做法,因为它们能为您带来更高的利润和更低的风险。
EA Studio 有一个非常棒的功能叫做相关性分析。它使用一个在低值和高值(0 到 1 之间)之间变化的系数,来确定策略之间的相关程度。
如果数值超过默认的 0.98,则表示策略具有相关性。为了设置系数,您需要前往工具 (Tools) -> 设置 (Settings) -> 相关性 (Correlation) -> 分析 (Analysis)。

系数越低,您在收藏集中看到的策略相关性就越低。
当策略的系数较低时,它们具有相关性,但相似性较小。相反,具有较高系数的策略则表示相关策略具有更高的相似性。
如果您没有在集合(Collection)中设置相关性分析以自动解决相关性,它将显示相关的策略,并且您可以通过点击绿色条来选择手动进行处理:

EA Studio 会考虑您在“排序记录”(Sort Records)中添加的准则,并将相关的策略标记为红色。当然,它不会标记该组中的第一个策略。

当程序检测到相关的策略时,“解决相关性”(Resolve correlations)按钮会变为绿色。当您点击它时,EA Studio 会移除重复的策略,并根据您的排序准则保留质量最高的策略。
您可以使用两种不同的算法运行相关性分析:一种基于平衡线(balance line),另一种基于策略的交易规则。在前往工具 -> 设置 -> 常规 -> 相关性分析(Tools -> Settings -> General -> Correlation Analysis)时,您可以选择其中任何一个选项。
如果您有一些尚未运行相关性检查的旧策略,建议将其上传并进行过滤,以便移除重复项。
策略集合 (Strategy Collection)
当您查看集合中的策略列表时,可以通过它们的 ID 和市场类型轻松区分它们。
以下是页面上的其他几个操作按钮:

MT4 专家顾问 (Expert Advisor for MT4)– 您可以下载该专家顾问并在 MetaTrader 4 中使用。
MT5 专家顾问 (Expert Advisor for MT5)- 您可以导出此专家顾问并将其应用于 MetaTrader 5。
添加到投资组合 (Add to Portfolio)– 一个非常实用的功能,允许您将当前策略添加到投资组合中。您只能执行一次此操作。
移除 (Remove)– 一旦您删除一个策略,集合中的策略列表就会更新。如果生成器(Generator)正在创建新策略,它们也会被包含在列表中。
您只需点击一下即可在编辑器(Editor)中打开策略。从那里,您可以对其进行检查或将其作为专家顾问下载。